Guide – Beadographer

Beadographer User Guide

Watch the Tutorials

Our tutorials are a quick and easy way to learn how to use the app.

Getting Started

On the opening page, you have two options:

When you click New Project, you have three options:

Choosing a pattern

Round beads and cylinder beads have six pattern options:

Fuse beads have three pattern options:

Choosing a size

With the exception of round patterns, you can also choose the size of your canvas. Choose square for most projects, and wide or long for long, thin projects such as bracelets.

Finding your way around

Areas of the screen

Beadographer has three areas:

If you click on the chest icon on the toolbar, another panel opens up. This is the bead library.

The gear icon at the top-left of the toolbar shows the menu, which gives you further options and tools.

Showing more tools

Some tools may be hidden, depending on the size of your browser window. To see the hidden tools, click on the ... button at the right-hand-side of the toolbar.

Showing more styles

Click on the → button at the top of the palette to see all the hidden styles.

Bead Cat

Bead Cat will give you hints as you learn to use the app. Click on Bead Cat to get extra hints. You can hide Bead Cat any time by clicking Hide hints. You can restore Bead Cat by navigating to Help → Show Bead Cat.

Keyboard shortcuts

Keyboard shortcuts (hotkeys) can speed up your work. They are listed in this guide in brackets after each corresponding function.

Quick start

Draw tool

The draw tool (D) is selected when a new project opens. This tool allows you to draw on the canvas. Simply click on the canvas and beads will appear. Change bead style by clicking on a different bead on the palette.

Erase tool

The erase tool (E) will remove beads from the canvas. You can also quickly access the erase tool while using the draw tool by holding down the shift key.

Paint tool

The paint tool (P) adds or changes entire regions of beads.

Rectangle tool

The rectangle tool (R) is used for creating rectangles of beads. It is useful for quickly drawing a lot of beads.

Undo and Redo

The undo tool (Alt + Z) undoes the most recent action. To redo an action, click the redo tool.

⚠ When you undo an action and then alter the canvas, you can no longer redo to return to a previous state.

Share

Use this tool to download an image screenshot of the current canvas view.

Working with project files

Important! Back Up Your Work

We recommend frequently backing up your work to avoid losing it. To back up your projects, you must download the files from ‘My Projects’ (the project browser). To download a file, select a file in ‘My Projects’, and click ‘Download’.

Autosave

Beadographer automatically saves your work as you go, during moments of inactivity. You can see if the file is saved by looking at the title of the tab in your browser. If there is a * before the title, then you have unsaved changes. Beadographer will save your changes each time you enter the menu, and whenever the mouse is still for a second.

⚠ Uploaded images and editing history are not saved as part of the file.

⚠ Projects are saved inside your internet browser. If you delete your offline data from your browser, you will delete all your projects. To save your projects outside the browser, you must download the files from ‘My Projects’. Select a file in ‘My Projects’, and click ‘Download’.

Rename project

Each new file is automatically called ‘Untitled’. To name your work, navigate to Project → Rename Project.

Duplicate project

To save a copy of this project, navigate to Project → Duplicate Project. This will add a shapshot of the current file to your saved projects. You can now continue to make changes and return to the snapshot later.

Project browser

The project browser lets you manage all the projects you have started. You can see the project browser by navigating to Project → My Projects. You have several options for working with files:

Change the view

Hand tool

The hand tool (H) moves and rotates the current view of the canvas. You can also move the view at any time with the arrow keys.

When the hand tool is active, the rotate tool appears in the center of the canvas. You can use this to rotate the camera, to work at any angle. Clicking on the button in the middle of the rotate tool will reset the angle. Clicking more times on the button will rotate the camera by 90 degrees.

Zoom tools

The zoom out tool (-) and zoom in tool (=) change the zoom of the current view.

Select beads

Marquee tool

The marquee tool (M) selects beads in a rectangular area. Click and drag on the canvas to select beads. Hold down the shift key to make additional selections. If you click on the marquee tool a second time, it will turn yellow. This indicates that you can copy selected beads by dragging them.

Select tool

The select tool (S) lets you individually select or deselect beads. Hold down the shift key to deselect beads. Click on an empty space to deselect all the beads. If you click on the select tool a second time, it will turn yellow. This indicates that you can copy selected beads by dragging them.

Color select tool

The color select tool selects all beads of one color and deselects all other beads. This is useful when you want to try changing the color palette of a project. If you click on the color select tool a second time, it will turn yellow. This indicates that you can copy selected beads by dragging them.

Transform tools

These five tools appear whenever the marquee, select, or color select tools are active. The transform tools allow you to transform the selected beads, either rotating or flipping them. Only the selected beads will move; other beads will not be affected.

⚠ When selected beads move on top of another bead, the unselected bead will be deleted.

Keyboard shortcuts

There are two extra keyboard functions for selecting beads. These shortcuts only work when the marquee, select, or color select tools are active.

Changing the style of selected beads

When any of the marquee, select, or color select tools are active, you can change the style of all selected beads by clicking on a bead in the palette. All the beads will be assigned this style.

Move or copy beads

When any of the marquee, select, or color select tools are active, you can move selected beads by dragging them. If you hold down Alt and drag the beads, you will copy the current selection. This is useful for quickly creating repeating patterns.

⚠ When selected beads move on top of another bead, the unselected bead will be overwritten.

Copy and paste between projects

To copy beads to another project, select beads you want to copy, then press Alt + C to copy the beads. Then open another project and press Alt + V to paste.

⚠ When copying between projects, the beads will be pasted in the same location in the canvas as where they were copied. You may need to change the view to see where they were pasted. They will overwrite any beads in the new location. If the canvas is a different size, the beads may not appear. If the type of bead is different in the new project, the beads will change finish and will lose their description.

Using the palette

Selecting a style

Clicking on a bead in the palette will select a style. If the marquee, select, or color select tools are active, this will change the style of the selected beads. If a non-drawing tool is active, the draw tool will become active when you select a style. The first 9 styles in the palette can also be selected using keyboard shortcuts 1-9.

Customize the palette

You can update the styles in the palette in a few ways. You can drag the beads around the palette to re-arrange them. To create a blank palette, click on the gear icon and navigate to Palette → Clear Palette. You can also save palettes and load palette files that you previously saved.

Using the prototype bead

The large bead at the bottom of the palette is the prototype bead. It shows the active style of bead used for adding beads to the canvas. Clicking on the prototype bead will show the color picker menu. You can also access the color picker menu by clicking on the palette icon in the toolbar.

The eyedropper tool

This tool allows you to select a style of bead on the canvas. The prototype bead will change to reflect the style you chose. It is useful if you want to select quickly the style of a bead you have added to the canvas. You can also access the eyedropper tool by holding down Alt while the draw tool is active.

The bead library

Another way to customize your palette is through the bead library. Click on the chest icon in the toolbar to open the bead library panel. When the bead library panel opens, a list of beads will be displayed. These are the beads from the library that most closely match the prototype bead’s current color. This feature allows you to search the library by color. If you update the prototype bead, the bead library will be re-sorted to match the new color of the prototype bead. You can scroll through the bead library results by using the up and down arrows on the bead library panel.

Searching the library

You can search the names and descriptions of beads in the bead library by typing in the search box at the bottom of the bead library panel. If you enter multiple words, it will apply multiple filters to the bead library; so, if you want to find beads that are both blue and opaque, you can enter “blue opaque.”

Search for a specific color

If you have a specific color you want to add to your canvas, you can enter a six-digit hex code (for example, 1a2e45) which represents that color. The prototype bead will immediately change to the color represented by that code, and the bead library will be re-sorted.

Adding or removing libraries

Navigate to Bead Library → Choose libraries to select which libraries appear in the bead library. Currently, the following libraries are available to use:

Beading mode

Starting beading mode

Beading mode highlights a row or column of beads to help you navigate through your work when creating it. To start beading mode, click on the beading mode tool, then click on the bead where you want to start your work.

Moving the highlighted beads

Click on the arrow buttons to move the highlighted row or column. Or, if you are using the keyboard, press Enter to advance the highlighted beads one space, and Backspace to move in the other direction. To change the orientation of the highlighted beads, click the circular arrow button, or press Shift. This lets you swap between columns and rows.

Info tool

Using the info tool

The info tool identifies the bead styles used in your project. It will add letters to any connected region of beads. Click on any bead from the region that you want to list, and letters will appear on your beads. Each letter represents a style used in your project. Beads with the same style have the same letter.

Download a bead list and word charts

When the letters are displayed, you can also download a list of beads as a text file. The letters in the bead list will correspond to the letters on the screen, so you can use this to prepare your beads for creating your project. The bead list will either display the product number and description of the bead (if the bead came from the bead library) or it will display an approximate description of the bead’s color (if you used the color picker menu to create the style.)

For brick, peyote, and loom designs, a word chart will be created that gives instructions on how to bead each line.

⚠ Word charts are only available for 1-drop brick and peyote designs. It will not work if you have shifted the rows using the Row Shifter tool.

Using an image file

Working with an image

You can add an image on top of the canvas as a useful reference for your work. For example, you could use it to trace animal shapes from photographs or designs you have made in other design tools. You can also convert this image into beads.

Upload an image

Upload an image either by clicking the image tool, or by clicking the gear icon and navigating to Image → Upload image. Accepted image types are .jpg and .png. If an image is already present on the canvas, it will be deleted. Only one image is supported at one time.

⚠ Images are not currently saved as part of project files, so if you want to work on the same image during a different session, you will need to upload it again and move it to the same place.

Move and transform the image

When the image tool is highlighted, you can move the image around the canvas by dragging it. The image tools also appear on the canvas. The upper slider controls the size of the image, and the lower slider controls the opacity (how transparent the image is). Dragging the red dot next to the image on the canvas allows you to rotate the image.

Convert the image to beads

To convert the image into beads, navigate to Image → Convert image. A dialog will appear that gives you options for converting the image:

Delete the image

To delete the image, click the gear icon and navigate to Image → Delete image.

Other tools

Mirror tool

The mirror tool lets you add beads in a symmetric pattern. To add a mirror, click on the mirror tool, then click on a bead where you want the mirror to pass through. Click Enter or click on the mirror tool again to change between four modes:

Note tool

The note tool lets you add notes to your work. To add a note, click on the note tool, then click on a bead where you want your note to point. Notes can be moved by dragging; they can be deleted by clicking the X next to the note. Notes are only visible when the note tool is active. Beads with a note have a * sign, which is always visible.

Ruler tool

To show the ruler, drag a line on the canvas. You can change the units between inches and centimeters by navigating to View → show units in cm/inches.

Row Shift tool

In round bead mode and cylinder bead mode, the Row Shift tool toggles the offset of an individual row. This allows you to create custom row patterns, for example combining 1- and 2- drop peyote.

View options

Tooltips

Tooltips remind you what each tool does and what its keyboard shortcut is. These hints can be disabled by clicking the gear icon and navigating to View → Hide tooltips.

Preview

Preview mode lets you view your work without the background grid. To see a preview, click the gear icon and navigate to View → Preview.